Byteplant Forum

Home » CleanMail Support » CleanMail Server Talk » Service does not start
Service does not start [message #1325] Fri, 18 November 2005 14:22
Alex Aracil
Messages: 3
Registered: November 2005
Junior Member

I recently chaged some settings in the configuration due to a open relay problem.
I decided to configurate the server with two IP adresses on the same server.
It was working OK before doing this, but after the change the service does not
I have Widows NT 4.0 and latest version of No Spam Today. When I try to do it manually I also get an error :

No Spam, Today! service could not be started on \\server.
Error 2140: Internal error in Windows NT

(aproximately, it is translated from spanish)

If I restart the computer, the service starts, but does not work properly.
Incoming email does not reach the server and I get an error all the time in the logfile:

("server ip" Valid name, no data record of requested type - closing session

I tried to reinstall software several time with the same result. Does anybody
found the same problem?

Re: Service does not start [message #1326 is a reply to message #1325] Fri, 18 November 2005 22:04 Go to previous message
Messages: 18
Registered: November 2005
Junior Member
check to make sure that each smtp service that is listening on port 25 is only listening on one ip addr (ie port 25 should be bound to ip1 for nst and ip2 for your mail server)

also check out this thread as i was receiving a similar error
Re: Service does not start [message #1327 is a reply to message #1325] Sat, 19 November 2005 08:56 Go to previous message
Messages: 121
Registered: February 2005
Senior Member
Also make sure the server hostname is in the \winnt\system32\drivers\etc\host file... if not you can get some strange errors on that with NT 4.0 ... I certainly did.

And check the services file in the same directory to see with port the smtp entry is on... by default it will be port 25. And exchange will then try to accept mail from port 25.

For example: I've setup NST to accept all inbound port 25 activity -- filter it and send it out on port 26. That means I had to change the smtp entry in the services file to have a value of 26 instead of 25 for exchange to work.
Previous Topic: SMTP
Next Topic: Point allocated to the AWL
Goto Forum:

Current Time: Mon Apr 23 09:26:03 CEST 2018