Byteplant Forum

Home » CleanMail Support » CleanMail Add-ons » virusfilter with CA antivirus
virusfilter with CA antivirus [message #306] Fri, 25 May 2007 16:26
Joris
Messages: 7
Registered: May 2007
Junior Member
Hi,

I'm trying to add a virusfilter using CA eTrust antivirus.
When I choose 'Computer Associates' as vendor, the command line is set correctly. But in the screen where I can set the result codes and the action, there is displayed 2 identical lines:

101 / Reject and Delete
101 / Reject and Delete

When I change a value in either line, the value is changed in the other line too. So I cannot make the 2 lines different.
When I try to continue, I get an error message, saying that there are 2 equal result codes, and I get back to the same screen.
When I delete one line, the administrator tool quits.

How can I resolve this?
Re: virusfilter with CA antivirus [message #307 is a reply to message #306] Tue, 29 May 2007 15:41 Go to previous message
support
Messages: 919
Registered: April 2004
Senior Member
> How can I resolve this?

The CAAV default config is broken. As a workaround, you can enter the settings by hand:

- Choose as the vendor
- use these settings (or similar):

Commandline:
%SCANNER% -ARC -NEX -LIS:%ERR% %IN%

Scanner:
c:\\program files\\CA\\SharedComponents\\ScanEngine\\inocmd32.exe

Exit codes:
0 --> accept/deliver
101 --> reject/delete



Customer Support
Byteplant GmbH
Re: virusfilter with CA antivirus [message #308 is a reply to message #306] Tue, 29 May 2007 16:08 Go to previous message
Joris
Messages: 7
Registered: May 2007
Junior Member
Ok, it looks like it works OK this way.

A bit strange: when choosing as vendor, you cannot browse to the scanner executable (inocmd32.exe) as the field is grayed out.

But I've put everything in one single line:

C:\Program Files\CA\Sharedcomponents\Scanengine\inocmd32.exe -ARC -NEX -LIS:%ERR% %IN%

(omitting the %SCANNER% variable of course)
and it seems to work ...

Thanks for the tip
Previous Topic: 550 Your message was not delivered for policy reasons with KAV
Next Topic: spamlogs for NST V3 doesn't output subject
Goto Forum:
  


Current Time: Sun Dec 04 23:25:27 CET 2016