Byteplant Forum

Home » CleanMail Support » CleanMail Server Talk » Attachment filter
Attachment filter [message #950] Fri, 10 December 2004 12:25
wawa
Messages: 1
Registered: December 2004
Junior Member
We are using nospamtoday V2.0.2.3.
If I activate the attachment filter for some extensions (e.g. exe bat scr), then all attachments without any extension are also blocked.
Ist this a bug or can I change the configuration, so that these attachements can pass?

Re: Attachment filter [message #951 is a reply to message #950] Fri, 10 December 2004 18:23 Go to previous message
support
Messages: 919
Registered: April 2004
Senior Member
> We are using nospamtoday V2.0.2.3.
> If I activate the attachment filter for some extensions (e.g.
> exe bat scr), then all attachments without any extension are
> also blocked.
> Ist this a bug or can I change the configuration, so that
> these attachements can pass?

This is a known issue. We'll change this behaviour in one of the next updates
so that attachments without an extension (this should rarely be the case) are
passed through.



Customer Support
Byteplant GmbH
Re: Attachment filter [message #952 is a reply to message #951] Wed, 22 December 2004 17:25 Go to previous message
Dave Camenisch
Messages: 30
Registered: December 2004
Member
> ... so that attachments without an extension (this should rarely be the case) are
> passed through.


Sorry, but attachments without an extension is NOT a RARELY thing. Macintosh user are sending a lot of files without extensions!!!

Please fix this asap. I can't use the attachment filter this way!

Regards,
Dave Camenisch

Re: Attachment filter [message #953 is a reply to message #952] Thu, 23 December 2004 12:44 Go to previous message
support
Messages: 919
Registered: April 2004
Senior Member
> > ... so that attachments without an extension (this should
> rarely be the case) are
> > passed through.
>
>
> Sorry, but attachments without an extension is NOT a RARELY
> thing. Macintosh user are sending a lot of files without
> extensions!!!
>
> Please fix this asap. I can't use the attachment filter this
> way!

Version 2.0.3.1 (released on Dec 22nd, 2004) contains a fix for this issue.
For a complete list of changes, please find the revision history here:
http://www.byteplant.com/support/nospamtoday/server/changes.html
The new version can be downloaded here:
http://www.nospamtoday.com/download/server



Customer Support
Byteplant GmbH
Re: Attachment filter [message #954 is a reply to message #953] Thu, 23 December 2004 14:09 Go to previous message
Dave Camenisch
Messages: 30
Registered: December 2004
Member
> Version 2.0.3.1 (released on Dec 22nd, 2004) contains a fix
> for this issue.

Version 2.0.3.1 it's still not working here. Instead of the original attachment I get an attachment named "blocked_attachment_info.txt". Inside this textfile stands "Name of blocked attachment: ReadMe".

I installed the attachment filter with standard configuration.

Here is the output from the log window:
Dec 23, 2004, 13:44:42 Session 0: (Attachment Filter) From: xxxx@xxxx.ch
Dec 23, 2004, 13:44:42 Session 0: (Attachment Filter) Subject: testfile
Dec 23, 2004, 13:44:42 Session 0: (Attachment Filter) To: xxxx@xxxx.ch
Dec 23, 2004, 13:44:42 Session 0: Received end of data, mail size 5kB
Dec 23, 2004, 13:44:42 Session 0: (Attachment Filter) Filter result is accept/deliver
Dec 23, 2004, 13:44:42 Session 0: (Spam Trap) No action
Dec 23, 2004, 13:44:42 SpamAssassin DNS server(s): 195.186.xxx.xxx 213.193.xxx.xxx
Dec 23, 2004, 13:44:51 Session 0: (SpamAssassin) Filter result is accept/deliver
Dec 23, 2004, 13:44:51 Session 0: (SpamAssassin) Spam score: 0.6
Dec 23, 2004, 13:44:51 Session 0: Incoming mail action: accept/deliver
Dec 23, 2004, 13:45:15 Session 0: Connection closed by client


Regards,
Dave
Re: Attachment filter [message #955 is a reply to message #954] Thu, 23 December 2004 14:40 Go to previous message
support
Messages: 919
Registered: April 2004
Senior Member
> Version 2.0.3.1 it's still not working here. Instead of the
> original attachment I get an attachment named
> "blocked_attachment_info.txt". Inside this textfile stands
> "Name of blocked attachment: ReadMe".

Hmm.

I just checked, and it seems this particular fix did not make it into the release. I just updated the revision history accordingly.

I'm sorry about this, it will be included in the next version for sure.



Customer Support
Byteplant GmbH
Re: Attachment filter [message #956 is a reply to message #953] Mon, 02 May 2005 14:39 Go to previous message
speedy
Messages: 1
Registered: May 2005
Junior Member
running v2.0.5.1:

We do also have the problem, when activating "Attachment filter" for only filtering MIME-errors. Then all attachments with an ending dot will be exchanged by blocked_attachment_info.txt. All other Files pass the filter quite correct.
So older Macintosh-Mails loos their attachment.
Is there another solution than deactiving the filter?
Re: Attachment filter [message #957 is a reply to message #956] Tue, 03 May 2005 12:32 Go to previous message
support
Messages: 919
Registered: April 2004
Senior Member
Thanks for bringing this to our attention.
The problem will be fixed in the next release.



Customer Support
Byteplant GmbH
Previous Topic: unexpected client disconnect
Next Topic: Message body/suject deleted
Goto Forum:
  


Current Time: Sun Dec 04 19:21:52 CET 2016