Byteplant Forum

Home » CleanMail Support » CleanMail Server Talk » No Configuration Text or Files Found
No Configuration Text or Files Found [message #768] Tue, 15 June 2004 17:05
edaniel
Messages: 2
Registered: June 2004
Junior Member
In running SA Learn, I notice the statement "No Configuration Text or Files Found" in the DOS dialogue. The program then proceeds to examine and learn, but I am concerend that what is learned is not being used from those messages that I have fed to the filter.

The command I am using is "sa-learn.exe --spam --showdots D:\site1\spam", where "D:\site1\spam" is the location I upload .eml message files that my Outlook express filter catches.

Using the -D option I find:

C:\Documents and Settings\webmaster\Desktop\N0-Spam Today>cd C:\Program Files\No
Spam Today!\sa

C:\Program Files\No Spam Today!\sa>sa-learn.exe --D --spam --showdots D:\site1\s
pam
debug: Score set 0 chosen.
debug: running in taint mode? no
debug: defining getpwuid() wrapper using 'unknown' as username
debug: using "/usr/share/spamassassin" for default rules dir
debug: using "/etc/spamassassin" for site rules dir
debug: using "C:\Documents and Settings\webmaster/.spamassassin/user_prefs" for
user prefs file
No configuration text or files found! Please check your setup.
debug: bayes: 1320 tie-ing to DB file R/O C:\Documents and Settings\webmaster/.s
pamassassin/bayes_toks
debug: bayes: 1320 tie-ing to DB file R/O C:\Documents and Settings\webmaster/.s
pamassassin/bayes_seen
debug: bayes: found bayes db version 2
debug: bayes: Not available for scanning, only 25 ham(s) in Bayes DB < 200
debug: bayes: 1320 untie-ing
debug: bayes: 1320 untie-ing db_toks
debug: bayes: 1320 untie-ing db_seen
debug: Score set 0 chosen.
debug: Initialising learner
debug: Initialising learner
debug: Syncing Bayes journal and expiring old tokens...
debug: lock: 1320 trying to get lock on C:\Documents and Settings\webmaster/.spa
massassin/bayes with 0 retries
debug: lock: 1320 link to C:\Documents and Settings\webmaster/.spamassassin/baye
s.lock: sysopen ok
debug: bayes: 1320 tie-ing to DB file R/W C:\Documents and Settings\webmaster/.s
pamassassin/bayes_toks
debug: bayes: 1320 tie-ing to DB file R/W C:\Documents and Settings\webmaster/.s
pamassassin/bayes_seen
debug: bayes: found bayes db version 2
debug: Syncing complete.
debug: Removing Markup
debug: Learning Spam
debug: uri tests: Done uriRE
debug: 5491655455.81515@edaniel>@dctconsult.com: already learnt correctly, not le
arning twice
.debug: Removing Markup
debug: Learning Spam
debug: uri tests: Done uriRE
debug: 200406142156962.SM01552@cm218-254-80-75.hkcable.com.hk: already learnt co
rrectly, not learning twice
.debug: Removing Markup
debug: Learning Spam
debug: uri tests: Done uriRE
debug: 7638832513712592.69681@edaniel>@dctconsult.com: already learnt correctly,
not learning twice
.
Learned from 0 message(s) (3 message(s) examined).
debug: bayes: 1320 untie-ing
debug: bayes: 1320 untie-ing db_toks
debug: bayes: 1320 untie-ing db_seen
debug: bayes: files locked, now unlocking lock
debug: unlock: 1320 unlink C:\Documents and Settings\webmaster/.spamassassin/bay
es.lock

C:\Program Files\No Spam Today!\sa>pause
Press any key to continue . . .

Any thoughts on why I am getting this message?

Thanks!



Post Edited (06-15-04 17:18)
Re: No Configuration Text or Files Found [message #769 is a reply to message #768] Tue, 15 June 2004 18:01 Go to previous message
support
Messages: 919
Registered: April 2004
Senior Member
> In running SA Learn, I notice the statement "No
> Configuration Text or Files Found" in the DOS dialogue. The
> program then proceeds to examine and learn, but I am concerend
> that what is learned is not being used from those messages that
> I have fed to the filter.
>
> The command I am using is "sa-learn.exe --spam --showdots
> D:\site1\spam", where "D:\site1\spam" is the location I upload
> .eml message files that my Outlook express filter catches.
>
> ...
> Any thoughts on why I am getting this message?

Please make sure you are using sa-learn this way:
cd [NoSpamTodayInstallationPath]
sa\sa-learn -c sa\ruleset --spam MessageFile
or
sa\sa-learn -c sa\ruleset --spam --mbox "[FolderPath]"

See also this HOWTO document on our website:
http://www.byteplant.com/support/nospamtoday/howtolearnspam.html



Customer Support
Byteplant GmbH
Re: No Configuration Text or Files Found [message #770 is a reply to message #768] Wed, 16 June 2004 15:14 Go to previous message
edaniel
Messages: 2
Registered: June 2004
Junior Member
Thanks for the information regarding the path i.e. sa\ruleset

For others using local (client ) detection of spam and using Outlook Express (.eml and .dbx folders), I found a freeware product (dbxconvert) that converts .dbx mailboxes to .mbx. Automating this via a batch file (on the client) allows one to upload the .mbx folder for SA-learn processing.

It simply copies the collection of spam to the dbxconvert directoy I created in C:, process the .dbx file and then deletes it, as folows:

cd\
cd\Documents and Settings\Ed Daniel\Local Settings\Application Data\Identities\{7E910D46-1F80-4F7E-8E4C-5EE469664F70}\Microsoft\Outlook Express
copy spam_save.dbx c:\mail_convert\*.*
cd\
cd\mail_convert
dbxconv -mbx *.dbx
del *.dbx
pause

Where C:\mail_convert is the directory that dbxconvert resides in and spam_save.dbx is the folder I created in Outlook Express that I move confirmed Spam emails to.

I also have a batch file on the server to call sa-learn, as follows:

cd C:\Program Files\No Spam Today!\sa
sa-learn.exe -c ruleset --spam --mbox --showdots D:\site1\spam
pause

One optimization I could add is a VBS routine to auto aupload the file to the server via FTP and schedule the client and the server process. Worth considering.

I handle HAM similarly, with slightly different batch files.

Previous Topic: Change notification's expeditor (MAILER-DAEMON@MyRelay.com)
Next Topic: Statistics
Goto Forum:
  


Current Time: Thu Dec 08 17:03:36 CET 2016