Byteplant Forum

Home » CleanMail Support » CleanMail SpamAssassin Filter » Bayes DB lost during upgrade?
Bayes DB lost during upgrade? [message #679] Thu, 20 May 2004 21:35
InforMed Direct
Messages: 59
Registered: May 2004
Member
When installing the latest upgrade, I *unchecked* the option to install a pre-learnt Bayes database as we've been training ours for several months.

We collect all spam that isn't trapped in a central folder on the network and once a day run SA-LEARN on all the messages in this folder. SA-LEARN skips any messages that it's already processed so we usually get a report along these lines:

Learned from 50 message(s) (1858 message(s) examined)

Where 50 is the new spam messages that have been received since we last ran the learner. So it skipped 1808 messages as it had already learnt from these on previous occasions.

However, after upgrading and running the learner, it reported:

Learned from 1491 message(s) (1858 message(s) examined)

Which suggests to me that it had forgotten about them due to the upgrade - is this because it's overwritten the database even though I unchecked the box? But if it had overwritten the database, why hadn't it learnt from all 1858 messages? I can understand a few duplicates but not nearly 400 of them.

It's not the end of the world as we do have this central copy of spam collected over the past 30 days (spam in the collection folder over 30 days old is deleted) so we can at least re-learn these messages.

Cheers, Rob.

Previous Topic: Filter by specific IP
Next Topic: SA learn & command prompt
Goto Forum:
  


Current Time: Sat Oct 01 17:27:58 CEST 2016