Byteplant Forum

Home » CleanMail Support » CleanMail Add-ons » IMAP2MBOX
IMAP2MBOX [message #215] Wed, 15 March 2006 17:28
B19WLL
Messages: 3
Registered: March 2006
Junior Member
Hi

I am having trouble using the IMAP2MBOX app. When I create a config file everything seems to be ok. The mbox is being created and the mails are being deleted from the "Public Folders\spam" folder.

The problem occurs when I run the learn spam batch file, I get the following error

IMAP login failed: 1 NO Logon failure: unknown user name or bad password.

I have created countless .cfg files that all log in ok and count the emails and delete them, but when I use the cfg with the batch file I always get the same error. I have even built a second exchange server (clean build) to try it on and I get the same results.

Please help

Regards

Will
Re: IMAP2MBOX [message #216 is a reply to message #215] Wed, 15 March 2006 21:05 Go to previous message
Heidner
Messages: 121
Registered: February 2005
Senior Member
Can you open a cmd box, run the bat script, then copy the ".bat" command line as well as the messages displayed. Paste them into a message box in this thread.

It sounds like when you run it interactively - it works. But when you reference the config file - that fails?

Are you by any chance creating the config file in one directory, then copying it to another location?

The reason I ask is that as part of the filename and path is used as part of the password encryption process. If you move the config file the password would not decrypt properly.
Re: IMAP2MBOX [message #217 is a reply to message #215] Thu, 16 March 2006 10:49 Go to previous message
B19WLL
Messages: 3
Registered: March 2006
Junior Member
Hi

Here is the batch file

rem learns an mbox mail folder as spam
rem
rem execute this batch in installation directory
rem
rem imap2mbox has been previously configured to read from the mail server and
rem export the emails into the mbox container called "spam.mbox"
rem
rem
rem A logfile called spam.log is created so we can monitor the activities of
rem imap2mbox and spam-learn. Spam.log should be deleted periodically
rem
del spam.mbox

echo *===* >> spam.log

imap2mbox.exe --config="spam.cfg" >> spam.log

if exist spam.mbox sa\sa-learn -C sa\ruleset --showdots --spam --mbox spam.mbox >> spam.log

sa\sa-learn -C sa\ruleset --showdots --force-expire >> spam.log

sa\spamassassin -x -C sa\ruleset --lint >> spam.log
pause


When I run it I get this error


C:\Program Files\No Spam Today!>echo *===* 1>>spam.log

C:\Program Files\No Spam Today!>imap2mbox.exe --config="spam.cfg" 1>>spam.log
IMAP login failed: 1 NO Logon failure: unknown user name or bad password.


C:\Program Files\No Spam Today!>if exist spam.mbox sa\sa-learn -C sa\ruleset --s
howdots --spam --mbox spam.mbox 1>>spam.log

C:\Program Files\No Spam Today!>sa\sa-learn -C sa\ruleset --showdots --force-ex
pire 1>>spam.log


yes it works great when I run it interactivley, and I do not move the config file after its created.

Thanks

Will



Post Edited (03-16-06 17:52)
Re: IMAP2MBOX [message #218 is a reply to message #215] Thu, 16 March 2006 19:35 Go to previous message
Heidner
Messages: 121
Registered: February 2005
Senior Member
please add the --debug and --verbose switches and run it again as a batch job. Then include the output. Also try the config switch without the "quotes" on the file name..

When you run the batch job is it running in the same directory as when you run it interactively? I.E. when you schedule a job - Windows will allow you to specify a directory.
Re: IMAP2MBOX [message #219 is a reply to message #215] Wed, 22 March 2006 17:35 Go to previous message
B19WLL
Messages: 3
Registered: March 2006
Junior Member
Hi

I have trie dthe config switch without the quotes, and I get the same error. I will add the --verbose and --debug switches and post the output here.

Will
Re: IMAP2MBOX [message #220 is a reply to message #215] Thu, 23 March 2006 01:19 Go to previous message
Heidner
Messages: 121
Registered: February 2005
Senior Member
Could you also post the config file that is generated... but alter your user name in the file first (change to xyz)... and delete the timestamp plus "magic" lines. This will allow me to try to figure out why the batch process isn't working.
Previous Topic: IMAP2MBOX
Next Topic: IMAP2MBOX login
Goto Forum:
  


Current Time: Sun Sep 25 10:48:42 CEST 2016