Byteplant Forum

Home » CleanMail Support » CleanMail Server Talk » Delay filter is being skipped
Delay filter is being skipped [message #2147] Thu, 27 August 2009 01:43 Go to next message
Griffyn
Messages: 19
Registered: June 2006
Junior Member
I've noticed that the delay filter has stopped working.

The partial log from a sample e-mail:
Aug 27, 2009, 09:18:17 Session 5: (Whitelist) Filter result is accept/deliver
Aug 27, 2009, 09:18:18 Session 5: Received end of data, mail size 20kB
Aug 27, 2009, 09:18:20 Session 5: (DNSBL Filter) Filter result is accept/deliver
Aug 27, 2009, 09:18:20 Session 5: (Attachment Filter) Filter result is accept/deliver
Aug 27, 2009, 09:18:20 Session 5: (Zip Filter) Executing: zipfilter/zipfilter bat chm cmd com cpl crt dll exe hlp hta inf ins isp js jse lnk msi msp nws ops ocx pcd pif prf reg ra ram rar rm rt scf scr sct shb shm shs shtm shtml swf url vb vbe vbs vbx vxd wsc wsf wsh zip
Aug 27, 2009, 09:18:21 Session 5: (Zip Filter) Command line exit code is 0
Aug 27, 2009, 09:18:21 Session 5: (Zip Filter) Filter result is accept/deliver
Aug 27, 2009, 09:18:21 Session 5: (Delay Filter) Filter result is accept/deliver (not filtered)
Aug 27, 2009, 09:18:21 Session 5: (SpamAssassin) Executing: sa\spamassassin.exe  -x --siteconfigpath="sa\ruleset" -e 255
Aug 27, 2009, 09:18:38 Session 5: (SpamAssassin) Command line exit code is 0
Aug 27, 2009, 09:18:38 Session 5: (SpamAssassin) Filter result is accept/deliver
Aug 27, 2009, 09:18:38 Session 5: (SpamAssassin) Spam score: 0.0
Aug 27, 2009, 09:18:38 Session 5: (Extract Attachments) Executing: ExtractAttachment "c:\Program Files\CleanMail\Attachments"
Aug 27, 2009, 09:18:39 Session 5: (Extract Attachments) Command line exit code is 0
Aug 27, 2009, 09:18:39 Session 5: (Extract Attachments) Filter result is accept/deliver
Aug 27, 2009, 09:18:40 Session 5: (Mail Storage) Message cached in C:\WINNT\Temp\filter_4A95C2B700050000.eml
Aug 27, 2009, 09:18:40 Session 5: Incoming mail action: accept/deliver


The config for the Delay filter is
[ServerSessionManager\Ports\SMTPPort\Filters\DelayConfig]

AddressListEx="passthrough@ourdomain.com passthrough@ourdomain.com"
Delay="32"


Why is the delay filter being skipped? On every e-mail I've checked so far that hasn't been on the whitelist or DNSBL, the delay filter shows 'not filtered'.
Re: Delay filter is being skipped [message #2154 is a reply to message #2147] Fri, 25 September 2009 16:26 Go to previous message
support
Messages: 919
Registered: April 2004
Senior Member
The delay filter is a stream filter and has to be moved upwards in front of the first commandline filter in the chain to be effective.

Customer Support
Byteplant GmbH
Previous Topic: Spam filter message initialization failure
Next Topic: Attachment filter: block Att. list....
Goto Forum:
  


Current Time: Sat Oct 01 03:28:54 CEST 2016