Byteplant Forum

Home » CleanMail Support » CleanMail Server Talk » No Spam for Servers Proxy Setup
No Spam for Servers Proxy Setup [message #1945] Thu, 14 August 2008 11:04
EliteIT
Messages: 2
Registered: August 2008
Junior Member
I've just installed the latest version of the software this morning & ran through the proxy setup again...

When I click on [Test] under the Port & Server Settings dialog box it returns an error of :

---------------------------------------------------------------------------------------------------------------------
The server returned an error (see below) while trying to send a message to . If your mail server is not fully compliant to IETF standards this may be OK. When in doubt, check the mail server configuration.

Protocol error: 554 5.1.0 Sender Denied
---------------------------------------------------------------------------------------------------------------------

We run Exchange Server 2003, one of my email addresses is postmaster@ourdomain.co.uk. The No SPAM Today proxy seems to work fine & filter out unwanted emails perfectly I'm just curious as to what is causing this error.

Any help would be appreciated.

Many Thanks

Lee Alison
Re: No Spam for Servers Proxy Setup [message #1946 is a reply to message #1945] Thu, 14 August 2008 16:16 Go to previous message
support
Messages: 919
Registered: April 2004
Senior Member
> I've just installed the latest version of the software this
> morning & ran through the proxy setup again...
>
> When I click on [Test] under the Port & Server Settings dialog
> box it returns an error of :
>
> ---------------------------------------------------------------------------------------------------------------------
> The server returned an error (see below) while trying to send a
> message to . If your mail server is not fully
> compliant to IETF standards this may be OK. When in doubt,
> check the mail server configuration.
>
> Protocol error: 554 5.1.0 Sender Denied
> ---------------------------------------------------------------------------------------------------------------------
>
> We run Exchange Server 2003, one of my email addresses is
> postmaster@ourdomain.co.uk. The No SPAM Today proxy seems to
> work fine & filter out unwanted emails perfectly I'm just
> curious as to what is causing this error.

When you hit the "Test" button, the NoSpamToday Admin wizard sends a test mail with <> as sender address to the recipient address at your mail server.
Even though some mail servers are not fully compliant to the RFC/IETF standards and this test may fail, this is no reason to worry as NoSpamToday will still be able to operate normally.



Customer Support
Byteplant GmbH
Re: No Spam for Servers Proxy Setup [message #1947 is a reply to message #1945] Fri, 15 August 2008 18:18 Go to previous message
James Wilkinson
Messages: 14
Registered: July 2007
Junior Member
On the other hand, you might want to receive e-mail with null envelope senders (this can be different to the "From:" address in the e-mail headers). You may be rejecting bounces, delivery reports, some out of office notifications, and various other automated e-mails. [1]

You may have problems sending your own e-mail, too: some e-mail servers may not accept e-mail *from* you if they can't send e-mail *to* you, and the half-way competent ones will try null envelope senders when they test. [2] (This is only a problem if e-mail goes straight to NoSpamToday and Exchange, not through another server first. If the delay filter stops any spam, then this is how you are set up).

None of this is a problem with NoSpamToday, but a problem with Exchange. A quick Google and check suggests that in the Exchange System Manager, you should go to Global Settings -> Message Delivery, right click, select Properties, choose the Sender Filtering tab, and turn off "Filter messages with blank sender".

Any advice the help gives you about "this might cut down spam" is only really accurate in that it will cut down on all e-mail, spam or wanted.

[1] These days, a lot of bounces are backscatter: see http://wiki.apache.org/spamassassin/VBounceRuleset for an explanation and a better solution than dropping all bounces. The VBounce ruleset is included in NoSpamToday, and merely needs whitelist_bounce_relays to be set in sa\ruleset\local.cf, as detailed in that link.

The SpamAssassin guys recommend that backscatter is dealt with separately to spam, and give a Unix recipe for handling it. On Windows, you may want to treat it as straightforward spam: I find
score ANY_BOUNCE_MESSAGE 4.2
works well. (Put that in local.cf, too).

[2] See http://taint.org/2007/03/16/134743a.html for more details: Justin is the lead programmer for SpamAssassin.

Previous Topic: Windows 2008 Server
Next Topic: Mail Storage Filter
Goto Forum:
  


Current Time: Sat Dec 03 18:40:39 CET 2016