Byteplant Forum

Home » CleanMail Support » CleanMail Server Talk » Error - Input line ends with
Error - Input line ends with [message #1194] Wed, 06 July 2005 13:43
clarke-pj
Messages: 5
Registered: February 2005
Junior Member
I have a new Exchange 2003 server on the network and I wish to port all the mailboxes over to it from our existing 2000 server.

The only problem is sending mails from the new server to the old server.
As NST and the old exhange server reside on the same box, NST is on port 25 and exchange SMTP server is on 26.

On mails from the new Exchange 2003 server I am getting the following errors.
(I've reset the IPs and domain names)
i am running NST 2.0.5.1 and both exchanges are patched up.

Thanks
Peter

Jul 06, 2005, 05:51:04 Session 0: Connection from 255.255.255.255 accepted on 255.255.255.254:25
Jul 06, 2005, 05:51:04 Session 0: 220 mail.MYDOMAIN.com Microsoft ESMTP MAIL Service, Version: 5.0.2195.5329 ready at Wed, 6 Jul 2005 05:51:04 +0100
Jul 06, 2005, 05:51:04 Session 0: EHLO MAIL02.MYDOMAIN.com
Jul 06, 2005, 05:51:04 Session 0: 250-mail.MYDOMAIN.com Hello [255.255.255.254]
Jul 06, 2005, 05:51:04 Session 0: 250-TURN
Jul 06, 2005, 05:51:04 Session 0: 250-ATRN
Jul 06, 2005, 05:51:04 Session 0: 250-SIZE 8290304
Jul 06, 2005, 05:51:04 Session 0: 250-ETRN
Jul 06, 2005, 05:51:04 Session 0: 250-DSN
Jul 06, 2005, 05:51:04 Session 0: 250-ENHANCEDSTATUSCODES
Jul 06, 2005, 05:51:04 Session 0: 250-8bitmime
Jul 06, 2005, 05:51:04 Session 0: 250-VRFY
Jul 06, 2005, 05:51:04 Session 0: 250-X-EXPS GSSAPI NTLM LOGIN
Jul 06, 2005, 05:51:04 Session 0: 250-X-EXPS=LOGIN
Jul 06, 2005, 05:51:04 Session 0: 250-AUTH GSSAPI NTLM LOGIN
Jul 06, 2005, 05:51:04 Session 0: 250-AUTH=LOGIN
Jul 06, 2005, 05:51:04 Session 0: 250-X-LINK2STATE
Jul 06, 2005, 05:51:04 Session 0: 250 OK
Jul 06, 2005, 05:51:04 Session 0: X-EXPS GSSAPI
Jul 06, 2005, 05:51:04 Session 0: 334 GSSAPI supported
Jul 06, 2005, 05:51:04 Session 0: TlRMTVNTUAABAAAAB4IIogAAAAAAAAAAAAAAAAAAAAAFAs4OAAAADw==
Jul 06, 2005, 05:51:04 Session 0: 334 TlRMTVNTUAACAAAABAAEADgAAAAFgomi6qz3DPdmzZsAAAAAAAAAAEoASgA8AAAABQCTCAAAAA9GAEQAAgAEAEYARAABAAwATQBBAEkATAAwADEABAAMAEYARAAuAGMAbwBtAAMAGgBtAGEAaQBsADAAMQAuAEYARAAuAGMAbwBtAAAAAAA=
Jul 06, 2005, 05:51:04 Session 0: TlRMTVNTUAADAAAAGAAYAGYAAAAYABgAfgAAAAQABABIAAAADgAOAEwAAAAMAAwAWgAAAAAAAACWAAAABYKIogUCzg4AAAAPRgBEAE0AQQBJAEwAMAAyACQATQBBAEkATAAwADIAznc+xDnYM60AAAAAAAAAAAAAAAAAAAAAZBMGH/OtkOXXZbXzIiFGgOLaQwUXxysH
Jul 06, 2005, 05:51:04 Session 0: 235 2.7.0 Authentication successful.
Jul 06, 2005, 05:51:04 Session 0: X-LINK2STATE LAST CHUNK={0000006a} MULTI (5) ({00000051} DIGEST_QUERY 13441f76d0991649b0fcf71447995e8d c2f2358818545d249d0404074ef15a12 )
Jul 06, 2005, 05:51:04 Session 0: 200 LAST CHUNK={00000029} MULTI (5) ({00000010} DONE_RESPONSE )
Jul 06, 2005, 05:51:04 Session 0: MAIL FROM: SIZE=3735
Jul 06, 2005, 05:51:04 Session 0: 250 2.1.0 migtesting@MYDOMAIN.com....Sender OK
Jul 06, 2005, 05:51:04 Session 0: RCPT TO:
Jul 06, 2005, 05:51:04 Session 0: 250 2.1.5 PClarke@MYDOMAIN.com
Jul 06, 2005, 05:51:04 Session 0: DATA
Jul 06, 2005, 05:51:04 Session 0: 354 Start mail input; end with .
Jul 06, 2005, 05:51:04 Session 0: (Attachment Filter) Subject: RE: TEST
Jul 06, 2005, 05:51:04 Session 0: (Attachment Filter) From: "migration testing"
Jul 06, 2005, 05:51:04 Session 0: (Attachment Filter) To: "Peter Clarke"
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:51:04 Session 0: Input line ends with
Jul 06, 2005, 05:56:05 Session 0: Timed out waiting for SMTP client - closing
Jul 06, 2005, 05:56:05 Session 0: Incoming mail action: delete (unexpected client disconnect)
Jul 06, 2005, 05:56:05 Session 0: Connection from 255.255.255.255 closed
Re: Error - Input line ends with [message #1195 is a reply to message #1194] Thu, 07 July 2005 20:17 Go to previous message
Heidner
Messages: 121
Registered: February 2005
Senior Member
The RFC's 822, 2822, 2060 (Ithink) for e-mails say that every command and text line must be terminated with a "CRLF" pair.

A few mail servers don't do that - or it may be the mail server is has a configuration error.

Improperly constructed e-mails (only LF or CR at end of lines) is a common attribute for spam -- so NST looks for the MIME errors and can delete the incoming messages. Even if accepted NST reports the errors.

If you enable the mail storage feature of NST you can capture the incoming e-mail as a ".msg" file. Then open it up with Word or a good programming editor. Enable the display of all special control characters and you can see the missing LF's or CR's.

That should let you back track to the new Exchange server and figure out why it is incorrectly formatting e-mails. There may be some box left unchecked...
Re: Error - Input line ends with [message #1196 is a reply to message #1194] Thu, 07 July 2005 22:22 Go to previous message
support
Messages: 919
Registered: April 2004
Senior Member
You are trying to move mail from MS Exchange to MS Exchange.
Microsoft uses a proprietary protocol for this, and NoSpamToday! gets confused.

To move the mails from old to new Exchange, disable (bypass) NoSpamToday! for this, at least temporarily while you move the mailboxes. It is sufficient if NoSpamToday! only checks incoming mail from the Internet.



Customer Support
Byteplant GmbH
Re: Error - Input line ends with [message #1197 is a reply to message #1194] Fri, 08 July 2005 10:16 Go to previous message
clarke-pj
Messages: 5
Registered: February 2005
Junior Member
Thanks for the replies.

I fixed this by changing the outgoing port of the New Exchange server to port 26 and using the old exchange server as a smart host.

This routes all the mails to the old exchnage server and to the outside world through the smtp server on the old exchange box, bypassing NST.

Peter
Previous Topic: License Counting
Next Topic: Relaying
Goto Forum:
  


Current Time: Sat Dec 03 07:46:06 CET 2016