Byteplant Forum

Home » CleanMail Support » CleanMail Server Talk » CPU Usage from spamassign.exe
CPU Usage from spamassign.exe [message #1512] Fri, 20 October 2006 14:53
thisbejoe7
Messages: 17
Registered: January 2006
Junior Member
I am running NST on a 3.2GHz HT P4 with 2GB of RAM. I get a lot of e-mail and lately have noticed that the CPU Usage on this powerful machine is pegged at 100% most of the time by spamassign.exe. There are several instances of spamassign.exe and together they consume all of my CPU resources consistently. Is there any way to work with this and reduce the load on the CPU? I only have an attachment filter, a single spamassign filter and a virus check filter. I set connection limits and timeouts, but my CPU usage is still pegged. Please help!

Thanks...
Re: CPU Usage from spamassign.exe [message #1513 is a reply to message #1512] Fri, 20 October 2006 15:52 Go to previous message
support
Messages: 918
Registered: April 2004
Senior Member
> I am running NST on a 3.2GHz HT P4 with 2GB of RAM. I get a
> lot of e-mail and lately have noticed that the CPU Usage on
> this powerful machine is pegged at 100% most of the time by
> spamassign.exe. There are several instances of spamassign.exe
> and together they consume all of my CPU resources consistently.
> Is there any way to work with this and reduce the load on the
> CPU? I only have an attachment filter, a single spamassign
> filter and a virus check filter. I set connection limits and
> timeouts, but my CPU usage is still pegged. Please help!

There are several things you can do, e.g.
- lower the "Memory Usage High Watermark" in the General Setup Wizard
- limit the number of simultaneous connections to 5 or 10 (default 1000) in
the SMTP Proxy Wizard.
Another option you should consider is to use a delay filter
(see http://www.byteplant.com/support/nospamtoday/howto-use-delay-filter.html
for details). Delay filtering usually blocks between 30% and 70% of all spam & virus mails
and causes only minimal resource usage.



Post Edited (10-20-06 17:27)


Customer Support
Byteplant GmbH
Re: CPU Usage from spamassign.exe [message #1514 is a reply to message #1512] Wed, 25 October 2006 17:39 Go to previous message
thisbejoe7
Messages: 17
Registered: January 2006
Junior Member
CPU usage is still really high, but the product still works, its just really really slow if I need to do anything else, even open the log files for NST, its just awefully slow because the hyper threaded CPU I have is pegged at 100%.

Thanks...
Re: CPU Usage from spamassign.exe [message #1515 is a reply to message #1514] Thu, 27 November 2008 22:02 Go to previous message
Maddog1970
Messages: 1
Registered: November 2008
Junior Member
I found this post http://wiki.apache.org/spamassassin/BayesForceExpire at Spamassassin that fixes it. What I did is added "bayes_auto_expire 0" to /etc/spamassassin/local.cf. Then I made a batch file and put "C:\Program Files\No Spam Today!\sa\sa-learn --force-expire" in it. Then created a scheduled task every hour to run that batch file.

Previous Topic: Service will not start automatically
Next Topic: Log analysis
Goto Forum:
  


Current Time: Sun Sep 25 05:42:46 CEST 2016