Byteplant Forum

Home » CleanMail Support » CleanMail Server Talk » Client Disconnects... Again
Client Disconnects... Again [message #988] Sun, 02 January 2005 22:44
bks2
Messages: 6
Registered: December 2004
Junior Member
OK,

So I see a lot of people have brought up the fact about client disconnects. Thought I would share some of my issues.

So, I have a backup mail server that typically receives all the mail first as I have it set as the "primary" through DNS so the most of all the spam traffic can be filtered through NST and deleted (I have the setting set to like 1.5 for all e-mail accounts except legit, used e-mail accounts... so they are deleted and not forwarded onto the main server where they continue to bounce for days).

Now, I get errors all the time about an unexpected disconnect from my backup server trying to relay legit e-mail to my main server.

I have noticed that when I telnet into the primary server on the port 25 and do the commands myself, I will enter the data, and then give the command that I am finished, typically a carriage return, followed by a period, followed by another carriage return.

Sometimes it will sit there for a good 30 seconds before it finally comes up with a "confirmation code" and indicates that the mail was accepted/denied for delivery.

Now, when I take NST out of the picture and do the telnet straight to my SMTP server, it immediately is accepted and it doesn't wait that 30 seconds or whatever before it is accepted/denied.

This is causing many client disconnects on my side, and it isn't exactly because it is spam mail. It seems that there is something that is hanging up NST that causes it to lag 30 seconds or so before it says that it accepts/denies the mail for delivery.

I have the RBL timeout set to like 5 seconds...?

I have 384 MB RAM running a 900 MHz processor.



Brian S.
A+, Network+, 2000 MCSA, CCNT
Re: Client Disconnects... Again [message #989 is a reply to message #988] Tue, 04 January 2005 21:21 Go to previous message
support
Messages: 919
Registered: April 2004
Senior Member
Your server does not have a lot of RAM, and not a particularly fast CPU, so 30s needed for spam checking is about acceptable. Decreasing the RBL timeout won't help, it is checking messages against all of SpamAssassin's filtering rules that takes its time, especially when you are receiving more than one message at the same time.

Anyway, a SMTP client (such as your backup server) is supposed to sit and wait while the SMTP server handles the delivery. The recommended timeout values as per RFC2821 are 5 minutes, sometimes 10 minutes (300s or 600s).

If your backup server uses the recommended timeout values, disconnects should not happen. Maybe you can reconfigure this timeout.



Customer Support
Byteplant GmbH
Re: Client Disconnects... Again [message #990 is a reply to message #988] Sat, 15 January 2005 21:25 Go to previous message
bks2
Messages: 6
Registered: December 2004
Junior Member
Thanks for the info.

I ensured that the backup server is set to timeout after 10 minutes.

While you bring up a good point about the RAM, I only have 128 MB RAM, 850 MHz in the backup server, and there isn't any delay on this server.

So, this is why I believe it is strange that there is a pretty good delay on the primary server with 384 MB RAM and 900 MHz.



Brian S.
A+, Network+, 2000 MCSA, CCNT
Re: Client Disconnects... Again [message #991 is a reply to message #990] Mon, 17 January 2005 12:29 Go to previous message
support
Messages: 919
Registered: April 2004
Senior Member
> While you bring up a good point about the RAM, I only have
> 128 MB RAM, 850 MHz in the backup server, and there isn't any
> delay on this server.
>
> So, this is why I believe it is strange that there is a
> pretty good delay on the primary server with 384 MB RAM and 900
> MHz.

Hmm. From reading your earlier posts, I'm not quite sure if your backup server does any spam checks at all. If it doesn't, this would certainly explain why it is faster.

Even if the backup server runs NoSpamToday!, it won't run as many SpamAssassin instances in parallel with only 128MB of memory, so each individual instance will finish faster.

If you reduce the setting "Memory Usage High Watermark" (File->Global Settings), you can certainly reduce spam checking time, though the overall throughput will be slightly reduced as well.

BTW, if your backup server already runs NoSpamToday!, use your mail server directly as the outgoing server, unless there is some other reason to run mail through NoSpamToday! again.



Customer Support
Byteplant GmbH
Previous Topic: 95% Spam?
Next Topic: No Connect from external adresses
Goto Forum:
  


Current Time: Sat Oct 01 03:29:58 CEST 2016