Byteplant Forum

Home » CleanMail Support » CleanMail SpamAssassin Filter » bayes databases lock failed
bayes databases lock failed [message #604] Tue, 23 November 2004 10:18
Greyhound
Messages: 6
Registered: June 2004
Junior Member
We have upgraded to NoSpamToday! V2.0.12 a few days before with no problems (review your rulesets (lint) there are some changes !!) without any problems . As I have reviewed the logfile today I have found some lines:

„(SpamAssassin) Cannot open bayes databases db\bayes_* R/W: lock failed: File exists“

Do we have a converting problem ? Any ideas ?



Post Edited (11-23-04 12:17)
Re: bayes databases lock failed [message #605 is a reply to message #604] Tue, 23 November 2004 11:01 Go to previous message
support
Messages: 919
Registered: April 2004
Senior Member
Bayes DB auto expire sometimes may take several minutes. Sometimes SpamAssassin 3.0 does not clean up a lock if it is interrupted.

Check this forum thread for the solution:
http://www.byteplant.com/forum/read.php?f=1&i=259&t=257#reply_259



Post Edited (11-23-04 16:59)


Customer Support
Byteplant GmbH
Re: bayes databases lock failed [message #606 is a reply to message #605] Tue, 23 November 2004 12:27 Go to previous message
Greyhound
Messages: 6
Registered: June 2004
Junior Member
Thanks a lot for the quick reply !!

There was a “.lock” file till I stopped the service. 

In our case, when the service was stooped the file was gone.

But never the less, after running the rest of the commands from the thread the line did not appear in the log for more than an hour. So I guess the problem is solved.

Thanks a lot
Previous Topic: Huge increase of low score spam
Next Topic: What do you have you NST score set to?
Goto Forum:
  


Current Time: Sat Dec 10 17:35:26 CET 2016